华为路由器ensp和思科Packet_Tracer做网络实验日常笔记

小鸡
阅读1909喜欢3·教程发表2018-12-30更新2018-12-30

前言:过几天网络实验课要机试考各种路由实验,用的是华为的模拟器ensp,于是现在有空就顺便在做一下练习,并记下笔记

老师给的题目有:

  1. telent服务器配置,完成远端访问
  2. icmp,设计网络结构,完成三种状态
  3. 路由跟踪
  4. 可变长掩码技术
  5. rip路由协议配置
  6. DHCP协议配置
  7. ARP协议(获取,变化)
  8. CIDR 最长浅醉掩码
  9. 高级访问控制列表

下面开始一个一个做,不过不按顺序,先从会的开始

DHCP协议配置

拓扑结构如下

兰州小红鸡

首先启用dhcp服务

dhcp enable

分别进入三个端口配置ip

[Huawei] int Ethernet 0/0/0

[Huawei-Ethernet0/0/0] ip add 200.1.1.1 28

[Huawei] int Ethernet 0/0/1

[Huawei-Ethernet0/0/0] ip add 200.1.1.33 28

[Huawei] int GigabitEthernet 0/0/0

[Huawei-GigabitEthernet0/0/0] ip add 200.1.1.65 28

[Huawei] rip

[Huawei-GigabitEthernet0/0/0] network 200.1.1.0

创建ip池

下面创建了一个名为pool1的ip池,并且进入端口0/0/0使用该ip池

[Huawei]ip pool pool1
Info:It&aposs successful to create an IP address pool.

[Huawei-ip-pool-pool1]network 200.1.1.2 mask 255.255.255.240

[Huawei-ip-pool-pool1]gateway-list 200.1.1.1

[Huawei-ip-pool-pool1]dns-list 202.106.1.1

[Huawei]int Ethernet 0/0/0

[Huawei-Ethernet0/0/0]dhcp select global

然后在pc1使用DHCP服务后,便可以获取自动ip地址

兰州小红鸡

然后就好啦

ping测试

兰州小红鸡

高级访问控制列表

创建基本的访问控制列表可由下面三个步骤完成,涉及的命令如下

  1. 创建一个编号从2000~2999的基本访问控制列表;
[Quidway] firewall enable           % 启动防火墙
[Quidway] firewall default permit % 设置防火墙缺省过滤方式为许可任何用户数据包的通过

[Quidway] firewall default deny % 使防火墙禁止任何IP包的通过

[Quidway] acl number 2000 % 创建编号为2000的基本访问控制列表

明天再做了

未完待续。。。

转战Packet Tracer

华为的ensp实在坑太多了,用不来,今天试了下思科的Packet Tracer,简直相见恨晚!太好用了,设备齐全,小白操作,一口气做了好多实验,舒畅!!!

兰州小红鸡

Packet Tracer做访问控制列表

之前用华为的ensp一直有命令问题做不出来,用这个好多了

基本访问控制列表

基本的简单,用到的代码就那些

基本访问控制列表: 
router(config)# access-list <number> permit|deny <source_ip> <wild|any>
router(config)# interface <interface> //进入端口
router(config-if)# ip access-group <number> in|out //将规则布置在此

教程里面的例子如下,自己的忘了截图

例 1: 
router(config)# access-list 4 deny host 10.65.1.1
router(config)# access-list 4 permit any
router(config)# int f0/0 router(config-if)#ip access-group 4 in
例 2:
router(config)# access-list 4 permit 10.8.1.1
router(config)# access-list 4 deny 10.8.1.0 0.0.0.255
router(config)# access-list 4 permit 10.8.0.0 0.0.255.255
router(config)# access-list 4 deny 10.0.0.0 0.255.255.255
router(config)# access-list 4 permit any
router(config)# int f0/1 router(config-if)#ip access-group 4 in

删除访问控制例表

router(config)# no access-list 4
router(config-if)# no ip access-group 4 in

高级访问控制列表

命令如下

access-list <number> permit|deny icmp <S_IP wild> <D_IP wild>[type] access-list <number> permit|deny tcp <S_IP wild> <D_IP wild>[port]

例 1

router(config)# access-list 101 deny icmp any 10.64.0.2 0.0.0.0 echo 
router(config)# access-list 101 permit ip any any
router(config)# int s0/0
router(config-if)# ip access-group 101 in

例 2

router(config)# access-list 102 deny tcp any 10.65.0.2 0.0.0.0 eq 80 
router(config)# access-list 102 permit ip any any
router(config)# interface s0/1
router(config-if)# ip access-group 102 out

WWW服务和DHCP服务

这个最简单了,直接在下面设备列表选择一个server服务器

兰州小红鸡

DHCP服务

在如下所示的地方,填上网关,ip池首地址,子网掩码,点上on开关就好了

兰州小红鸡

然后在需要DHCP服务的pc机子上开启DHCP就好了

FTP服务

这个更简单了,server服务器默认开启这玩意

账号为cisco 密码为cisco

兰州小红鸡

在需要连接FTP服务的机子上输入命令

$ ftp <ftp服务器的ip>

然后提示输入账号密码,就ok了

兰州小红鸡

telnet服务

这个也还好,步骤如下

  • 在配置好端口的路由器或交换机中,设置本地登陆密码
Switch# configure terminal
Switch(config)# enable password 123(明文密码)
  • 开启交换机远程登录及验证
Switch(config)# line vty 0
Switch(config-line)# password 123  (Telnet密码为123)
Switch(config-line)# login local

login是开启远程登录密码验证,login local不但要求TELNET密码,还要求提供用户名

  • 添加可远程登录交换机的用户
Switch(config-line)# exit
Switch(config)# username levy password 123
Switch(config-line)# exit
  • 然后就可以在pc机子上测试了

兰州小红鸡

Icmp协议和ARP协议

老师给的提示太少,没听懂

可以看b站这两个大佬视频

icmp视频
ARP视频

至于可变长掩码技术和CIDR最长前缀匹配,还没看,今天就做到这。

参考文章

Cisco packet tracer下配置DHCP方法 关于Cisco Packet Tracer DHCP中继配置实验的更新 Cisco Packet Tracer中配置TELNET 哔哩哔哩——网际控制报文协议ICMP的应用
随想
博客
机器学习
教程
邻家酒肆
前端
深度学习
算法
小程序
资源
cpp
html
javascript
python
sql
node

最近文章